I can not have access to my server anymore

Suddenly my server stopped to work today, the 14th April.

I have a survey occurring right now in the field, with a team of 20 enumerators and I have been working with the server normally, even today I made some downloads of the data.

However, this night when I tried to access to the survey solutions headquarter/server in order to do some assignments for the team that are in the field for the tomorrow’s data collection, I did not managed to access and received a message saying that I must contact my system administrator to resolve the issue. The message says exactly the following: “The application has encountered an unknown error:(Please contact the system administrator to resolve this issue”

I don’t know who is the system administrator. Is he from Survey Solutions team or from the the Amazon where my server is allocated?

How can I solve this? Who may assist me? Please see bellow the screenshot of the information that I received:


Go to the person that gave you the credentials to access the HQ. Ask them to escalate until they find out who the system administrator is.

You didn’t wright what the server address is (URL), so no idea really who that might be.

Thanks Sergiy.

Unfortunately, the person that gave me the credentials to access the HQ is no longer reachable as he left the company and can’t find the credentials.

However the server name is: cowimoz
URL: ec2-18-221-129-197.us-east-2.compute.amazonaws.com

Can you please help me?

Sounds like you are asking me to hack into somebody’s data server.

  1. I have no way to establish that you are in any way associated with that server.
  2. I am not familiar with that IP-address or any server that may be running behind it.
  3. Survey Solutions code doesn’t leave any backdoors to hack into the data server in the manner like you are hoping for.

If this is indeed an Amazon AWS server, then somebody must be still paying for it, and that person can probably get some support from AWS as to how to restore access to that instance.

Even if that person who setup the server in the first place can’t find credentials to login to the server, he/she may still be in control of the email account associated with AWS to which the instance was opened. In that case restoring the access should be done through the AWS control panel.

Overall, this sounds very weird. Do you not care where your data is stored and who has access to it? And what to do in case of an emergency? Or even for routine tasks like backup or updates of the server… Do you know even what the version of Survey Solutions was installed there? Or how much more storage has been left available before starting the survey?

Best, Sergiy

I thought that this issue were related to survey solutions credentials not Amazon. I have access to amazon management account and I will contact them.

Thank you

Ok. This is some good news!

The issue may be related to either Survey Solutions or the hosting.
I have no way to tell. But in order to troubleshoot, you need access to the logs, and for that you need access to the virtual server, see the last paragraph here:

Once you have access to the server via remote desktop connection, do the troubleshooting and also use the support tool to create a Survey Solutions admin account for yourself:

And finally, decide what to do with the existing account of the person who has left. Perhaps, changing his/her password to something else will prevent you from that person accessing your data without you knowing or agreeing to it.

Hello Sergiy.

I could not had access to the virtual server following the documents that you sent.

Definitely the issue is related to Survey Solutions. I have contacted the Amazon AWS and they responded in the following way:

"Sounds to me like your application running on the server has hit an error, so you’ll need to contact the application’s vendor. The AWS shared responsibility model for EC2 means that AWS are responsible for the hardware and network security etc. but the customer is responsible for OS configuration and the applications running on it. So AWS can’t help you with this one, sorry. " see the screenshot below.

However, during the night and after we had a conversation, almost from 01:30AM to 05:30AM Mozambique time, the access to the server was regained without doing nothing by our side but now the server is inaccessible again!

One of the thinks that may caused this issue is the fact that we started to record interviews in our applications. This is the only new thing that we added from our normally work with the Survey Solutions applications, so this maybe is the reason that caused the issue with the server. I am not sure.

In other hand, I received information that my email (eza@austral.co.mz) is also associated to the headquarters for the server cowimoz.

Is there anything that I can do by my side?
Could please access to our server (as a provider) to check this issue?

My email associated to the Headquarter in the server is elias.zavale@gmail.com with login name elias (not eza@austral.co.mz)

Amazon’s answer is correct. They are not responsible for any errors in any software that you add to their servers. But you have not yet identified the reason for the problem.

  1. The problem could be in our code. The logs would show the particular error that the server encounters. Login to the server to check the logs.
  2. The problem could be with environment, for example, the server ran out of storage space. (perfectly fits your story and observed symptoms, happened to a few users already). Login to the server to check the storage situation.

For both cases you need to login to the server as the Windows Server admin (not the Survey Solutions administrator). You have confirmed that you have access to the AWS control panel (in your words “amazon management account”), but haven’t indicated whether you have access to the machine as an Windows Server admin user. Correspondingly, if you can’t login to the machine, seek Amazon’s help in getting this access, not troubleshooting the Survey Solutions application, of which they would have no idea.

No. As I already wrote above, the Survey Solutions application doesn’t have any backdoors that would allow the program’s authors to access users’ servers.

I have no idea what this means. Confirmation from whom? What is “cowimoz”? Is that the same server as the IP mentioned above? Is there a domain name for that server?


Many thanks for your support Sergiy.

I am not the Windows Server admin of the company but I will check with him tomorrow morning.

However, for a couple of minutes I had access to the server and I searched in the administrator tab and found that there are 14 errors that may cause this issue. I took some screenshot. See below. I didn’t have enough time to go to the logs page because the access was interrupted.

And when I instantly get the access to the server, the data exportation is not working indicating that “Request failed with status code 500” and the assignments are also not working ( PL0000 : An unexpected error occurred".

The message indicates that the DB has too many connections to it, which doesn’t allow any new query to it, including login queries.

What is the Survey Solutions version that is installed on your server?
If this is not the newest version, see if the update to the current version helps.

Many thanks for your useful support.

The issue is now solved and were related to the out of storage space in the server disk.

Dear @gitozavale ,

thank you very much for confirming the problem was related to the lack of the storage space, which was one of the candidate reasons I suggested earlier in I can not have access to my server anymore - #9 by sergiy

With this regard see the recommendations here: Server storage space

Best, Sergiy