URGENT: Not able to install the interviewer app on the android version 4.4.2

Dear Sir

We are not able to install the interviewer App on our tablet with Android with version 4.4.2. Can you please help us in understanding Why. We did-not have this issues till now.

https://support.mysurvey.solutions/faq/what-tablets-should-i-buy-/
The minimal requirement for the Tablet OS is Android 5.0.

This may (and will) change in the future.

Dear Sergiy

What is the frequency for change. I mean after how many years will you change the version for Android again. I ask this because we will have to buy the latest that is available now. We were not looking at the version much. As long it was 4 and above we bought it.

This change in the minimal requirement of Android OS happened at the beginning this year according to the release notes for version 19.04.. It is in red at the end of the release notes.

the short answer is - we don’t know. this depends on how the manufacturers extend the support of their tablets, provide upgrades and Android version capabilities and vulnerabilities.

We have declared the intent in 19.02, indicated the last pre 5.0 compatible version in 19.04, and the first version requiring A5.0 was 19.06.

I would not recommend buying tablets if their Android version is not marked as ‘supported’ here: https://en.wikipedia.org/wiki/Android_version_history