Unable to upgrade the assignments

We uploaded a new version of our questionnaire and also selected upgrade all assignments. Usually, this works without a problem. But this time the process is stuck. I cant update manually also. The process gets stuck in the same place. Attaching screenshot.

Try to refresh your page.

Upload a new version of your questionnaire again and refresh your page while do this process.

@kv700032 I did refresh. I also tried upgrading the assignments manually. I tried logging out and in. Different browsers. Nothing worked.

I don’t understand refreshing the page while upgrading.

A few days ago I had the same problem, but I just waited a moment and updated the page and the update was successfully completed.

@kv700032 I started the process and kept it that way overnight. Still no success.

@sergiy suggestions?

I tried importing the questionnaire again. Issue persists.

Screenshot below:

Should I create new assignments for all interviewers and archive the old ones? I am not sure how this behaves. What will it do to the existing flow of interviews? Will the interviews be able to still complete their already started interviews? Will the supervisor / HQ be able to reject or approve the interviews from old questionnaire?

Or is there something that the SS team can do at the backend to fix this?