Troubleshooting help for CAWI survey

I have set up a CAWI survey using a demo server and it is working well. I can’t create or download a link for the online survey in my cloud server though and need some help.

I have set up a cloud server using AWS. I have installed Survey Solutions on the server and it seems to be running well (https://www.mb-survey.com/). I have imported the questionnaire from Survey Designer created an assignment and enabled the web mode. When I’m trying to download the web link, I am only getting an empty folder.

Does anyone know what the problem could be? I would really appreciate some advice.

In order to receive a link to an assignment please make sure it is assigned to interviewer account, not supervisor.

Thank you for your quick answer. I assigned an interviewer account to the survey. This does not seem to be the problem. Any other idea?

is web interview mode started on questionnaire?

A web assignment created in the name of non-interviewer will give a proper warning. Have you seen that?

Reassigning to a different user (non-interviewer) will give another warning have you seen that?

Even if the assignment is made in a name of a non-interviewer should still be downloadable.

Also

  1. check in the properties of an assignment whether the link icon is shown and leads somewhere, such as (for example)
    https://www.mb-survey.com//WebInterview/HB6VZC9A/Start
  2. check the version, you may have created assignments in one version, but download web links from another.

Thank you so much for your comments. I finally figured out what the issue was. The problem was actually with the browser (/browser settings?). I used Firefox to log in. Downloading the online survey link resulted in an empty zip-folder. The same steps in Microsoft Edge or Internet Explorer created the links in the zip-folder. Going through the IP address instead through the DNS with Firefox also created the tab files.

Not sure why that is the case - but it is something that I can deal with now.

@mbecher, Thanks for the update. Please try to replicate the same at the demo server using any questionnaire.

If you manage to replicate - there is probably something wrong with our code. If not - there is likely something strange with your particular setup.

Please take a note of the versions of each browser when the issue was observed. Then check if updates are available and see whether the problem persists in the updated version [of FireFox].

Best, Sergiy Radyakin

I was able to download web links with firefox without any issues

It works now after changing the Firefox security settings. I had to uncheck ‘Block dangerous downloads’ under ‘Block dangerous and deceptive content’. When these two boxes are checked, I’m only downloading an empty folder. When the boxes are unchecked, I’m getting the txt file with the link.

I could not reproduce the problem with the blocked download of web links in Firefox Browser v79.0 using our demo server. The file that is downloaded is a valid zip archive with the proper web link. I have the security settings set same as @mbecher .

This could be because the site of mbecher is blacklisted (by site name) for any reason.

The following article (on Firefox support) explains how to get removed:
https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work
This would also explain why the download worked when acquired using an IP and not the domain name.

But I find it rather alarming that Firefox allows itself to selectively delete content and without explaining to the user what got deleted and where. Perhaps there are other messages (such as in status line, or in the download manager, etc) indicating that such a transformation has been done. Otherwise, how can you be sure that it is not silently transforming your data downloads???

Perhaps it’s worth mentioning in the corresponding Mozilla Firefox support forums and get their clarification.

Best, Sergiy

PS: I assume “empty zip-folder” means “zip archive file with no archived content” (typically of size 22 bytes). If anything else is meant, please elaborate.