Translation of reusable categories not uploading properly


I have a question with options bound to a set of reusable categories. In the translation Excel template, the options appear in a separate tab which can be translated. However, when those translations are uploaded, they do not appear (and when the translation Excel file is redownloaded, that tab is now blank again).

Screenshots below. Can you pleas advise?

Good day @dfrancis ,
I have tried to reproduce the issue according to described scenario and my redownloaded Excel file includes early added translated categories. Could you please add specific steps and, may be, share your questionnaire with me?

Thanks! I just shared the questionnaire with you. The steps are the following:

  • Using the translation template, we entered translations under both the “Translations” tab and under the auto-generated tab @@@_Active_ISO_Country_Codes_UN, which is the category of reusable options

  • The translations were uploaded, no errors in compiling, etc.

  • However, for the relevant bound questions, the options do not appear in the translated languages

  • To verify, I redownloaded the Excel sheet for each language, and the options tab is now blank.

Any assistance would be greatly appreciated.

Dear @dfrancis ,
Looks like we found the source of the issue and will address the fix in the next release. As work around I would suggest you to make shorter name of the Reusable categories (eg. Active_ISO_Country_Codes) this will allow you to add translations.

Thank you! So if we make a shorter name, it will work?

Yes, it will work with the shorter name (eg. Active_ISO_Country_Codes).

It worked. Thanks for the workaround.