This site can't load google maps correctly

Hi there,

We have a questionnaire where we pre-load our GPS coordinates to a GPS type question, which then display the location on a google map. This worked perfectly fine until this morning when we have noticed that all our Interviews display a blank map with the following error written over the blank map: “This site can’t load google maps correctly” Pre_loaded_Coordinates

Could you please advise if there is something wrong on our side or if something has changed on Survey Solution’s side?

We are currently running a local server on version 18.06.2. We have tried to update our test server (local) to version 18.08.2 but we still have the same issue.

Kind Regards
Eugene Ehlers

Google changed its API policy on Aug 18th. This is why you experience that problem. We are are preparing an instruction for our uses on how to resolve it. Briefly, you will need to create your own API key to google maps and put that key into your config file to activate the free google map services for your server. We should be able to provide more details instructions on that process shortly.

1 Like

Thank you Misha, I appreciate your feedback.

Hi Misha,

Do you perhaps know when the Instructions on how to resolve the Google API key would be released, and where would I look for the Instructions from Survey Solutions once it is released?

Kind Regards
Eugene Ehlers

Eugene,

Here is a short version for now

  1. Go to the Google Cloud Platform Console.
  2. Enable Maps Static API if they are not enabled
  3. Create or select a project.
  4. Click Continue to enable the API.
  5. On the Credentials page, get an API key .
  6. Replace old api key in web.config of Headquarters web site to a new one in: configuration->appSettings->Google.Map.ApiKey

Also please take a look into Google Javascript Maps pricing page: https://cloud.google.com/maps-platform/pricing/sheet/ for details regarding free usages limit

2 Likes

Victor,

Thank you for the detail.

Kind Regards
Eugene Ehlers

Hi Victor,

We’ve made the changes as per your instructions but it did not seem to resolve the issue. We made the changes on our local Development server but when we test the changes we found that only one of our interviews displayed the map correctly, as for the rest, they all still show the same as per my original screen shot attached to this thread.

Could you please advise?

Kind Regards
Eugene Ehlers

Hi there,

I have not yet received any feedback on my last post. We have created our own Google API key and included that into our web.config file but we only found one interview that displayed the maps correctly when viewing the Interview through the Headquarters software, the rest of our Interviews all still display a blank map with the following error written over the blank map: “This site can’t load google maps correctly”.

Are we doing anything wrong on our side or is this a known issue?

Kind Regards
Eugene Ehlers

Hi Eugene,

Sorry for delay.

I’ve try to do it on my local installation and found out and error in my steps.

There is more API should be enabled in point 2.

  1. Enable Maps Embed API and Maps Javascript API

Good day Victor,

We’ve followed your instructions step-by-step and we have created our API key based on the three API’s that you indicated and we have included all three API’s in the API restriction and updated our web.config with our generated API key, but we are still not able to view our pre-loaded maps (pre-loaded GPS coordinates) in the Head Quarters software. Neither are we able to view any of the GPS questions that has been captured on the tablets.

Kind Regards
Eugene Ehlers

Hi Eugene,

It’s my fault.

You should edit Configuration\Headquartes.config file. Settings there will override any values in root web.config file

Victor,

We have no Headquarters.config file in the configuration directory, only a Headquarters.web.config which I assume you meant in your previous communication. However this may be, this is the only config file in the Configuration directory, so we added our API key in the Headquarters.web.config file but there is still no change.
We are still not able to view our pre-loaded maps nor maps based on GPS questions captured via the tablet.

Any suggestions?

Kind Regards
Eugene Ehlers

Eugene,

Try to restart IIS(World Wide Web service)? Maybe changes haven’t apply.

Victor,

Yep, we did that already.

Any other suggestions?

Kind regards
Eugene Ehlers

Let’s summarize on what have been done(or should) Just to be on same line.

  1. Created own API Key for Google Maps. That include Maps Embed APi, Maps JavaScript API and Maps Static API
  2. Ensured that there is no Application restrictions enabled.
  3. Changed setting in Configuration\Headquarters.web.config with key Google.Map.ApiKey value equal to API key.
    • <add key="Google.Map.ApiKey" value="YOU API KEY" />
  4. Just to be sure - remove same setting line with old key in root\web.config file.
  5. Restart IIS

If nothing works - let’s test that API key is correctly setted up.

If key is working and all 3 Api’s working fine. Then I can propose to go through remote session via Teamviewer to inspect config files and see if there is an error.

Hi Victor,

We’ve gone through your steps and we have re-created out API key but still we are having problems viewing our maps. we also tested our API on the three URL’s you provided in your last communication, but for the ‘Maps Static API’ we still get the following message when navigating to
https://maps.googleapis.com/maps/api/staticmap?center=Brooklyn+Bridge,New+York,NY&zoom=13&size=600x300&maptype=roadmap&markers=color:blue|label:S|40.702147,-74.015794&markers=color:green|label:G|40.711614,-74.012318&markers=color:red|label:C|40.718217,-73.998284&key=YOU_OWN_API_KEY_HERE

For ‘Maps Javascript API’ we tried to test using the URL you provided https://jsfiddle.net/api/post/library/pure but we get a ‘404 That page doesn’t exist.’ error message when trying to navigate to the URL.

The ‘Maps Embed API’ is the only one that seem to be working correctly using the URL you provided https://jsfiddle.net/06Lfovzj/

When viewing our Interviews in the Headquarters software we have noticed that the very first map (GPS question) that is displayed will show the map correctly, however any GPS questions we view there after will show the same error that we see when testing the ‘Maps Static API’.

Kind Regards
Eugene Ehlers

Hi, Eugene,

Have You changed YOU_OWN_API_KEY_HERE string with own ApiKey?

I’m very sorry for Your troubles.

It seems to be very strange. I will try tomorrow all my own steps, and create new API key for own installation from scratch. Maybe I’m missed some config.

Victor,

Yes we did substitute our own API key where specified, but for obvious reasons I have omitted our API key in my communication.

It is strange indeed. We appreciate any help and feedback.

Regards
Eugene Ehlers

Step 1

Creating key in Google Cloud Platform - https://console.cloud.google.com/apis/credentials

1.1 Choosing API Key

Select API key in dropdown selection:


I have set nothing in OAuth consent screen and Domain verification

New Key created.
image

1.2 Restrict API Key

To Maps Javascript, Embed, Static Api’s

Step 2

Apply key change to Headquarters.web.config

Step 3

Check Headquarters. Everything is working now. At least for me.

Eugene,
Can You provide errors that are visible in Chrome dev console(F12) when You load page with maps that do not work.

Try this URL to test Javascript API
https://jsfiddle.net/wL3cxm4d/