The link has expired

Dear Survey Solutions Team,

I have set up a web survey and e-mailed the link to a number of respondents successfully.
I again tried to set up a web survey with a revised questionnaire, and created another link. When following the link, a message " The link has expired" appears.

Kindly assist.

Regards,
Sheona

Dear Sheona,

can you try the same link from a different browser, different device? Does it start the interview?

Best, Sergiy

Hi Sergiy,

Thank you for your prompt response.

I have sent it to my vodamail e-mail account, which is different to the employer. The following message appears when following the link " This site can’t be reached".

Kind regards
Sheona

Sheona, as I understand the message has nothing to do with Survey Solutions and indicates that the device you are using can’t reach the server.

Assuming that the second device is not restricted in any way in accessing sites:

  • If you are using our cloud server, check whether the server is still online following these procedures:
    https://support.mysurvey.solutions/faq/server-not-working/

  • If this is a standalone server you will need to contact the server/network administrator and ask them for assistance in resolving this matter.

The particular email account that was used to receive the link shouldn’t matter. You can print the link and retype it from paper, or communicate it using other media. So “vodamail email” is not a culprit as long as it displays you the received link undisturbed.

Dear Sheona,

do you maybe have sent the link through a dedicated email software that is not Sendgrid or AWS? In my last CAWI, the client I worked with has shared the link with various mailing lists through the “newsletter2go”-email provider.

While the link was displayed correctly, clicking on it has redirected you three times before actually reaching the server on which Survey Solutions was hosted. This has caused the problem that you described above. Almost all respondents saw the page “The link has expired”. If they would have copy + pasted the link from the email it would have caused no issues and a new interview case would have been created!

Hope that helps to track down your issue!

Best,
Peter

1 Like