Tester app stopped

Dear support team, Survey Solutions,

After successful compilation, when the questionnaire is accessed through the tester app, an error message is displayed while opening few sections in the questionnaire (Section M, Section P1); other sections are working fine. The same questionnaire is functioning well in the web browser.

I tried to do debugging to find any mistake in the design, but did not succeed. I request the support team to help me assist in resolving the tester app problem.

The designer file that I am working on is, https://designer.mysurvey.solutions/questionnaire/details/b50f6283f4234ceab38606c1688afb3e/chapter/d9a861d155fc4d78a8a9b6ba227cc584/group/d9a861d155fc4d78a8a9b6ba227cc584.

Thanks

Abilash A

Use the Interviewer App to instantiate an interview and once it crashes (if it does) see the logs for the recorded errors.

After accessing the problematic section through interviewer app (the app crashed), the following is the action log information recorded at the headquarter PDS.


I am unable to identify the issue. Requesting the help from support team

Thanks
Abilash

https://docs.mysurvey.solutions/headquarters/config/support-packages/

@sergiy
The following drive link has the tablet information package from the device. abilash89-demo-opinterviewer4-20210903T07-35-24.zip - Google Drive

Thanks
Abilash

The information we are looking for is, for example,


which indicates that the problem is probably related to a multiselect question. There is only one multiselect question in e.g. section M.

You said that the webtester doesn’t crash. But does it actually make your questionnaire work as intended? I couldn’t make a selection of a household member in question M3 no matter how I tried. It could be the logic of the questionnaire (which is not straightforward, why would you do the list of both the names and the IDs of the hh members?? this is bound to yield errors)

Please check and try to reduce the questionnaire to a bare minimal example that still reproduces the error.

Many Thanks!
After removing the linked multi-select question from the section, the issue got resolved.

As the linked multi-select are not allowed as the source for new roster question, I created a redundant list question asking for member ID’s of HHM participating in the group to be used as roster source.

Thanks
Abilash

this is true

This is suboptimal. There will be mistakes difficult to catch. Such as person N deleted from original list, then added a new person. Your second list will not be aware of this. You can get away with filtering the list-triggered roster by selection of the members in a linked question. This was definitely discussed in this forum somewhere.

Well, this helped to diagnose what the culprit is, but anything that gets compiled should not crash. Hence the puzzle remains what specific settings in your configuration have caused it to crash. If you can reduce your questionnaire with a problem to a minimal questionnaire with only the questions necessary to reproduce the problem that will help the investigation. See for example: https://github.com/surveysolutions/surveysolutions/issues/1404

The following questionnaire is reduced to the contents with the problem (the tester, interviewer app stopping) being present. I see that the issue is arising when the answers for list question in one section is referenced as multi select question in other section.

https://designer.mysurvey.solutions/questionnaire/details/5758f1a9a8744a758d3499ea5686086a/chapter/c661e2c4e882441abc36a87c3927fd51/group/c661e2c4e882441abc36a87c3927fd51

Even though the answers for list question are given, these are not displaying as options in multi-select question ('No results found). This null referencing could be the cause for app crashing.

Thanks
Abilash

The pdf file of the corresponding questionnaire reproducing the error is.Interviewer_App_diagnosis (1).pdf (186.2 KB)

Dear @abilash89,

thank you very much for working on the minimal example to reproduce the issue. In fact the second roster appears to be irrelevant, and the issue is still reproducible if the question M3 is moved to the questionnaire level, in fact even to the same section.

The actual reason for the problem is an invalid combination of the parameters of the question M3. You would notice that if you try to set up the source of categories, that although the ‘List question or questions from roster group’ is selected, it is not offered in the menu of selections there:
image
Correspondingly, if you switch to e.g. 'Reusable categories’ you will not be able to switch back.
After playing for a while with the dialog controls, I think I have figured out how you’ve managed to do this.

An immediate workaround is to switch from ‘Combo box’ to a ‘Checkboxes’ presentation, which should be working. More deeply however, rework your questionnaire to get rid of the indices. Your question clearly points that you wish to select NAMES not INDICES. For that the source is the original members list. Finally, on the software level that combination should be signaled as inconsistent, and prohibited, or the software expanded to support it fully. The main issue here is I believe that if your source has duplicates, e.g. X is entered as #1 and #7, then when you seek for X in a combo box, there is no way to tell which one to be actually picked (which code).

Hope this helps, Sergiy

Using Checkboxes solved the issue. Thanks