Synchronisation completed with errors

One of your interviewers is not able to sync interviews with the server. The issue seems to be with the completed interviews. He has 4 completed interviews that won’t sync. When they are moved to the started tab, the sync process completes without errors, but when those interviews are complete, sync complete with errors is returned.

I tried sending all tablet information to HQ for troubleshooting, but here the package is generated, but when I try sending it to HQ, I again get an error Unexpected Error. Trace logs are sent without issue.

Trace Logs

Additional Info: These assignments had audio audit turned on. I tried turning off audio audit and re-syncing. But this didn’t help. This is the only interviewer for whom we had audio audit turned on for a few assignments.

Hello @ashwinikalantri ,

thank you very much for your question.

The log contains the message “audioaudit failed with status code 413 (Request Entity Too Large)

So the problem appears to be related to the size of the audio audit file. Apparently something in your network blocks the transfer of a large file.

There are two possibilities:

  1. Either the file size is huge and the default settings need to be raised, or
  2. Something is non-standard about your network that prohibits transfer of large files.

To separate between these situations, do a backup of the data on that interviewer onto the file system of the tablet (option #5 here), and check what is the total size of audio audit of the remaining interviews and how is it split between multiple recordings.

@sergiy, thank for the reply. I just got my hands on the tablet and was able to generate the backup file. Surprisingly, the audio audit folder is empty. I am attaching a screenshot of the files and folder in the archive.

Also, I am not able to find audio files in the exported data from the interviews that have successfully synchronised with the server. I exported zip archive in Stata format. The options I get for this questionnaire are zip archive and paradata. Am I looking in the wrong place?

Hello @ashwinikalantri ,

judging from the file listing you are showing the size of audio audit recording is not excessively large. Correspondingly we can eliminate hypothesis #1 in favor of hypothesis #2.

Please consult the network administrator for existence of:

  • load balancer;
  • proxy server;
  • firewall;
  • WAF;
  • other devices/security mechanisms that were imposed on your network to inspect/control the traffic.

Especially WAF configuration leaves a lot of possibilities for misconfiguration.
Often times it is exactly as described here:

Please do let us/users know how this is ultimately resolved.

Best, Sergiy

The issue was with the configuration of upload parameters in NGINX. We are able to sync these interviews once these parameters were changed.

Hello Ashwini, was it just this NGINX configuration parameter?
http://nginx.org/en/docs/http/ngx_http_core_module.html#client_max_body_size
Or was anything else involved?

Thank you, Sergiy

Yes, this was the only parameter changed to resolve the issue.

Thank you for confirming!