Speed report showing no results found when there are completed interviews

I have about 250 interviews that have been completed on my server right now. However, when I look at the average interview duration in the speed report for that specific questionnaire, I see “No results found.” I tried choosing a specific version but did not solve the issue. I also tried changing the time in the over the previous selection but still same issue. I was wondering why I am seeing this issue. Does it have something to do with how average interview duration is calculated?

Thanks!

The message “no results found” is shown when the page is loaded first, then it is [usually very quickly] replaced with the content of the report. Or it stays if indeed there is no information to build the report.

  • Check the internet connection, give it some time to finish building the page;
  • Is this a local server?
  • Try to replicate on a demo server - so far the report is building there correctly.
  1. Good internet connection with very fast speed. My network speed is at about 50 Megabits per second. I left the page open for the last 15 minutes and it still says “No results found”
  2. It is a cloud server
  3. I quickly completed 2 interviews using the same template (MAIN CIAS19 QUESTIONNAIRE) and sent it back to the demo server. Report is not building on the demo server also. I also left the page open for the last 15 minutes and still “No results found”
1 Like

Lena, thank you for additional info. I also see no stats for this report.

  1. Did you fill out the interviews on the tablet or using the web? Can you try the opposite?

  2. To exclude any dependency on the time zone, let’s wait for 24hrs and check the report again. it may be the data selector that doesn’t pick the interviews if it thinks they are ‘from the future’.

PS: Envy your internet connection :slight_smile:

  1. Filled out using tablet. I am trying to fill out a webmode interview on the demo server but it keeps telling me “The link has expired” when I navigate to the link for the assignment (id 110866). Are web mode interviews not allowed on the demo server?
  2. Still showing no results.

Update on my server, there is now only 2 interviews out of about 9,000 showing up on the Speed report.

This has now been reproduced, confirmed, and added as a bug.

Thanks @sergiy! Appreciate your help.