Server proxy connection

Hi,

I can`t login to Designer on my own server to import a questionnaire.

In our scenario we use windows server 2016 with interntet connection realized through explicit proxy (security reasons) How I set up proxy connection on this server for use by survey solutions application (buid [20.8.1.29049])? System settings or “Netsh winhhttp set proxy setting” doesn’t work.

Thanks.

Hi, martinb

According to MS article proxy connection should be used by application by default.

But if it doesn’t happen, then You can set proxy settings manually.

Add HTTPS_PROXY or ALL_PROXY environment variable with ip:port of the proxy.

You can either set those variable as global system variables, or update Survey Solutions web.config file with proper values, as state in this SO answer for example: https://stackoverflow.com/a/37455594/41483

In Survey Solutions case this will look like this:

1 Like

In case of use solution described in this article,
next problem appear: Server export connectivity check error

Any idea to solve both problems simultaneously?

Thanks