QR code scan error with Workspace name

When I try to login from the interviewer app using the QR code, the retrieved link from the QR code scan displays the link with the workspace name. With the workspace name in the link, I cannot log in to the survey solutions interviewer app.

This is the error message displayed:
(supervisor website address is invalid. make sure that you entered the correct url address)


But when I remove the workspace name from the link, I can login to the interviewer app.
However, it works for the web interface, even with the workspace name.

Hello @maape,

  1. I could not reproduce the problem you’ve reported at the demo server. Try to replicate there.
  2. I could not reach your server using the information shown at your screenshot. Perhaps, the problem is with the server, not with the Interviewer App?

Dear sir

We are having the same problem at our end. The interview login was working perfectly before the new server update. Since then only this problem has been showing up. Any ideas about what could be going wrong would be of great help.

Thanks

We are using a Survey Solutions Personal Demo Server.

The original message posted by @maape indicated that the he/she finds that the namespace encoded in the qrcode prevents the Interviewer App from successfully contacting the server to verify the interviewer login. While the description of @priyankaecondse refers to the tablet already initialized, where the interviewer was already logged in and communicating. I don’t see that as “same problem”.

Immediately upon receiving the original problem report I have tried to reproduce it without success (demo server https://demo.mysurvey.solutions):
image
So given the description provided the problem is not reproducible.

What are the exact steps you were doing that led to the problem?

Let me describe the precise problem again.

We are unable to log in to the interviewer app which is showing the following error (see the screenshot). (We are using the PDS assigned by Survey Solutions.)

We had been using the app for our interviews before the update and they were working perfectly. Now today when we tried using the same login credentials then it was showing this error in the app “supervisor website address is invalid. Make sure you entered the correct URL address”.
So then we tried creating a new workspace and started afresh by creating new interviewer, supervisor ids and a new assignment. And it is still showing an error. (screenshot)

Many thanks

We also tried replicating this on the demo server https://demo.mysurvey.solutions and the problem persists.
Id and password used on this :
Supervisor: TestSuper1
Interviewer : TestInter1
(id and password are the same)
Attached is the screen shot

Thanks

what is the version of the tablet Interviewer App that you are using?
I tested with 20.12.0

The version we are using is 21.01 (build 28673)

We have hosted survey solutions in the Microsoft Azure cloud server. The problem is not with the server but with the QR code scan. When I remove the workspace name from the supervisor URL it works fine.

The interviewer version we are using is 21.01 (build 28673)

When I use QR code scan this is the link I get:
https://nbssurveysolutions-webapp.azurewebsites.net/hiesphone

With this link, I get this error message

But when I remove the workspace name from the link “/hiesphone” it works fine.

When i removed workspace name from the supervisor URL it works fine.

Understood.

@maape, thank you for raising the issue and @priyankaecondse thank you for clarifying the problem occurs specifically with the v21.01 of the Interviewer App.

We will modify the Interviewer App to recognize the QR-code generated by the HQ component without the need for manual corrections.

For the moment, please, use the workaround indicated by @maape (remove the workspace name trailing in URL) or type the server address without using the QR-code scanner.


[This defect has been assigned an internal number KP-14570.]

Thank you @maape. This is useful for now.
Thanks @sergiy for looking into this.