Problems related to interviews "disappearing"

Multiple users reported interviews “disappearing” in the tablet Interviewer App after ‘Complete’ was clicked by the interviewer. Another symptom is that in such a case the assignment button allows to create another interview even if 1 interview was requested in the assignment.

If you’ve noticed this behavior:

  • your interview data is still stored in the tablet Interviewer App;
  • do not reassign the assignment (or rejected interviews) to other interviewers;
  • do install the most recent version on the top of the current version, when started it will “discover” and visualize the cards corresponding to all the stored interviews.
  • do not uninstall the existing version as this will erase the data with it.

Version 19.07.4 should be applied as a fix to this issue.

Please update before retrying the interviews, as repeated interviews may not be needed.
See also this thread if there is any problem with updates:

@andrii @sergiy can you check the diagnostics we sent you today. Multiple users on 19.07.04 have issues with the completed forms not moving from started to the completed tab.

Will look into it. Thank you.

@sergiy @andrii

One of our enumerators is having the same problem described by ‘jebujohn’ above. When clicking complete on an interview (either new or responding to comments on rejected interview), the completed interview does not move from started/rejected tab to the completed tab. Other enumerators do not have this issue, despite using the same version of SurveySolutions app (19.07.04), Android OS version, tablet make/model, etc. This issue only arose after the recent SurveySolutions app update. Please can you advise how to address this issue?


We are looking into it. Seems like actual status of the interview is not the same as displayed on dashboard. We are working on a fix for this. Sorry for inconvenience.

Thanks @andrii. We have since noticed some instability in this issue - different enumerators running same setups affected at different times. Some are also reporting that when they hit complete on an interview, it disappears entirely from the dashboard. I’m assuming in all cases no data has actually been lost?

Hi. I have sent one more diagnostic dump. This one the form remains in started for key id 17-08-25-16
Like @timfoster88 said the problem is sporadic but for those affected the data is not synced to the server.

what is interviewer login for this interview?

No data was actually lost. Update application to 19.07.4 and restart Interviewer application

A few users experiencing the same problem have reported that restarting the application (in v19.07.4) helps alleviate the problem. Please follow this advice temporarily, while we are looking for the cause (and the fix) of this problem.

This worked for us for now

Hi Sergiy,

We are facing the same issue at

The problem is exactly as it is described by other colleagues above: the interviewer completes a questionnaire, the interview is not visible in the interface, and the interview is not posted to the server.

The problem was spotted when a user with version 19.07.04 competed three questionnaires and attempted a sync. The output of the sync was: “sync completed: nothing to sync”. We are attaching a picture with the logs of the user and hope you find it useful.

Please let us know if there’s any other useful information that you require from our side.


Sorry!! the problem is fixed after restarting the app.Thus, if you sign out and in, the problem is fixed, the interviews are visible in the interface and they are posted to server afrer sync!!!

We confirm that the problem has been fixed on our side!


1 Like

Hi Sergiy.,

Was a solution found for the problem mentioned in that thread? Our teams are still facing the same issue and need to log out and log back in each time they want to sync their complete cases. This is not dramatic and it does actually not impact our work but it is not really convenient or comfortable for interviewers, as you can understand. Maybe I missed the update?
Thanks a lot.


Dear Benjamin,

my colleagues are investigating. Different tablets exhibit different behavior. We do not at the moment have a scenario that would fail in our testing environment, but we’ve heard of several reports of this occurring.

At this time we need the reprosteps that would allow to reliably provoke the same situation in the testing environment.

If you do have them, please send to support.

Best, Sergiy

Hi Sergiy,

Well understood. After your last email, I tried to reproduce the steps that may lead to the error myself, but each time I completed a case, all went well and it successfully appeared in the “completed” tab. But I know from our field teams that the issue is still there. Will try again today.
Thanks for your reply.