Number of variables explodes after downloading data for combo box type questions

Hi.

In my current system, I have two forms; After one form has been filled in, that answer is incorporated into the next form in a function of “Identifying and collected data”. And I had been able to do this without problems till around September, but today when I tried, it didn’t work.

So I checked the downloaded data, and realized in the form, the number of variables for combo box type questions was exploding. For instance, the question which has originally 11 variables has 200 variables in total. Let’s say the name of the variable is A1-A11, then now it has increased to A199 and also A0 appeared with the value of -999999999.

Do you have any idea what is going on, and how I can fix this?

I really appreciate your help.

Which error message did you get?

Hi Sergiy,

Thank you for your prompt response.
I am getting the error message PL0014,
“Provided question value not allowed.” for those variables which suddenly appeared for downloaded data.

Please post a screenshot of how this question is configured in the Designer as the export format affected by the tweaks you do in the Designer,

Pl0014 is explained here:
https://support.mysurvey.solutions/headquarters/preloading/errors-in-user-supplied-files-for-preloading/

Thank you Sergiy.

Here is how the question looks like.
It has 11 choices.


When I look the list of variables from the “creating multiple assignments” and " DOWNLOAD .ZIP TEMPLATE FOR THIS QUESTIONNAIRE" , it looks OK with only 11 variables.

But if I download the form and see the list of variables, it has 200 variables…

Hello Kazusa,

the reported behavior is a bug. The number of variables generated from a multiple-choice question should be the smaller number of the:

nvars=Min(200, nchoices, nmax)

where nchoices is a number of categories in the multiselect question, and nmax is the restriction on maximum number of selections.

Apparently in this case the number of variables is 200 regardless of the other values, which is incorrect.

My immediate reaction was to specify the max number of selections to be equal to number of choices (11 in your case), but that still didn’t help.

This is a bug and we will fix it. The number of columns will be smaller (11 in the case of the example shown).

Note that in this case (combobox presentation) the data is not a set of dummies, but a set of selections, so var__0 will have the code of the first item selected, var__1 will have the code of the second item selected, and so on. Other variables will have a missing code.

After the fix the number of variables will be smaller (variables after var__10 will always be missing, since there are max 11 choices, so all choices will be accommodated by the first 11 vars making the remaining ones obsolete/nonsense).

If you are using a script for a statistical package, it should scan the observation var__* from left to right and stop on encountering a missing value. When written generically, such script would equally tolerate the buggy (current) and correct (after fix) versions of exported data.

Or you could manually patch it right now (if you know all your multiselect variables in combobox mode), e.g. in Stata:

capture drop varname__11-varname__199

The command capture will ensure that your script remains in working condition even after the fix will remove these variables.

Best, Sergiy Radyakin

1 Like

Hi Sergiy,

Thanks for your prompt response.
I somehow managed to deal with it using R now, but it would be great if you could fix it.
Note that when I change the question to checkboxes rather than combo box, this problem does not occur, so the issue seems to be related to that.

Best,
Kazusa

Hello to both.
About the topic , I say that we are having the same problem . Actually we are working in a local server with version 19.10.4 (build 26078). I made the design of a survey using the combo box type as the display mode of a categorical multiselect question and doing a previous test I found this problem and I started a reserch in the forum.
In a previous survey (last october 2019 with version 19.6) we made with success the data processing using the same type of question desing so we didn´t have the problem, so is it relationated with the version? Kazusa reported the problem in November.
Was the problem solved in another version?.
In other side about the reports with the latest version of SS we are not receiving It in our emails some long time ago. Is SS sending it or not sending it anymore ?

Hello, Alicia,

the problem with multiple variables in the exported data was documented in Nov 2019 and subsequently fixed. Please update the local server to the newest version 20.03 released this week.

On the second question - we are sending critical notifications on server startup and stoppage, etc.
You can always refer to version history here: https://support.mysurvey.solutions/release-notes/ which is updated with each release.

Ok Sergiy, as always thank you very much for the support!!