No content on the survey solution platform

Hi Everyone. So the server is set up and the Survey Solutions app is installed on the server. But when I open the app all I see are headings such as “Survey Setup”, “Data Export” etc. When I click on any of these headings nothing happens, there is no content. Where has the content gone? Please Help.

What is the server name/address?
When was the last time you saw your content?

@sergiy Thank you for your response. I never saw any content. I ran the test to make sure it was set up properly and I got the “healthy” message. But I also notice that I am not able to connect to it from another device using the IP address.

  1. What is the server name/address?
  2. What do you mean by ‘content’?
  1. What device? Connect how? What error message are you getting?

@sergiy Server name EC2AMAZ-V899V51, IP

Content in terms of dropdowns to import questionnaires (Survey Setup), do export data (Data Export). When I click on these nothing happens.

I tried connecting to the server using a web browser on a laptop that is connected to the same network by entering the IP address ( Error message " Hmmm… can’t reach this page took too long to respond"

This is a class B private address.
What is the public IP address for this server?

@sergiy Public IP:

I can’t see it either.
Most likely the server is not exposed to the internet.
Check the “Post installation configuration” section here:

(especially the Firewall sub-section).

@sergiy Thanks a million, will look at these and report my results.