No connection to server

Dear SSol community,

We are working on a local server and since last week we are having a problem with some tablets.
We are using following Samsung Galaxy Tablets:

Tab A(2016) with Android version 5.1.1
Tab A7 with Android version 11.

On Tab A(2016) tablets, whenever we try to sync, the following error appears “Synchronization was interrupted, please tray again. No connection to the Survey Solutions Supervisor. Please make sure that the website is available”.
We tried to do diagnostics with “test bandwidth to server” and it always appears “No connection to server”, but URL is correct. On the other hand, with A7 Tablets everything works correctly.
We’ve tried to look for solutions, but we haven’t found it because we still don’t really know what’s going on. We would greatly appreciate your support.

You’re not giving much information about your setup itself (what versions of Headquarters and Interviewer apps are running, how connection is setup etc) but let me make one guess, if you are running your server over secure http protocol (as everyone should) some certificate in your chain may be expired.

For example, root certificate of Let’s Encrypt expired on September 30, 2021. I don’t immediately know what specific steps you need to take as it will depend on what setup do you have on your server and the devices, but internet is full of these news for last several weeks (one example here)

Dear Zurab,

Thank you very much for your quick response.
We are using 21.09 (build 31655) for Headquarters and 21.09 (build 29787) for Interviewer. Yes, we are running server over secure http protocol.
You’re right, I was just reading in the let’s encrypt community via the following link

O problema pode estar nos certificados para os Androids 5.1.1. Mas estamos já trabalhando nisso e assim que conseguimos resolver o problema postaremos as etapas para a solução.

Regards,
PDDC