Map reports broken in 21.06

Hi

We run multiple HQs based on 21.01.8 and are now testing 21.06 using official docker images.

In 21.06 (build 31454) everything seems to work well except for Map reports.
We use the exact same Google Map configuration as before, which worked fine in 21.01.

Please see screenshot attached.
This is not the usual error we get because of API restrictions or Google billing issues. This is different.

Any idea why this is happening?
Thanks

Stan Ozier
SPC Pacific Community

Dear Stan,

Thank you for reporting the issue. My colleague has just notified of hotfix v21.06.1 addressing this specific issue. Please see if the problem persists after the update.

Best, Sergiy

Thank you, map loads properly on 21.06.1 :slight_smile:
We’ll continue our tests next week, but it looks good so far.

Dear Stan, thank you very much for the prompt confirmation. Have a great weekend, Sergiy

Dear Sergiy,

I just consulted this post and realized we have the same issue with our current server:

Unless I am wrong, I think that we are using version 21.06.3 (built 29729) for our pretest. Is the issue caused by our AWS settings or is this a SuSo issue?
Thanks a lot.
Best regards,

Benjamin.

No

No

This is a Google Maps issue. Click the “Do you own this website?” link in the window that pops up.
For 3rd party explanation see this link:

Hi Sergiy,

A FAO colleague and I managed to fix the issue. I had managed to go as far as creating the API key but I had no idea about where to paste it! My colleague showed me where:

  1. Connect to your EC2 instance;
  2. C: drive > Survey Solutions > site > appsettings.Production
  3. Enter: [GoogleMap] ApiKey=pasteyourAPIkeyhere
  4. Stop and re-start your EC2 instance and that should do the trick!

Of course this is assuming you already created the API key in the Google Cloud Platform.
Problem solved! Thanks a lot.
Benjamin.

This is part of standard configuration after the installation, see here: