Map Max filesize

Hi folks,

I have again a map size problem. While I was able to upload 12 GeoTifs larger than 50MBytes last week, the system today refuses to do so. Even the files I already uploaded get rejected today. I still can upload files with size less than 50MByte and I can upload the large files to the demo server.

I run my own IIS, the web.config says





hence 600MByte shouldn’t be a problem.

This must be a server issue, where else can I search? I try the upload on the server directly, so it cannot be a proxy problem, right?

Ralph

Can you analyze the changes between the last file was successfully uploaded and today? What did you change?

See may be this 3rd party info:
Increasing the Maximum Upload File Size in IIS - KB306 - Inflectra.

PS: your post doesn’t show the content of the config file you seem to have intended to share.

There is still a 500MB Survey Solutions limit:

Thank you Sergiy,

The problem is: I didn’t change anything. I now updated to the latest version. Still no success. I am trying files of 175 MByte. And the files uploads correctly to the demo server.

<security>
  <requestFiltering>
    <requestLimits maxAllowedContentLength="629145600" maxUrl="10241" maxQueryString="20481" />
  </requestFiltering>
</security>

What version of Survey Solutions are you using?

The very last one. 22.02.5 (build 32369). But there were the same results with the February version before.

Is there a limit for the total of maps uploaded? I currently have 10.1 GByte in 23 files in the MapsData-Folder of the project. There is sufficient disk space (still 437GB free) on the server. It looks like the map files are not stored in the PostGres database, so PostGres limitations do not consider maps, right?

No, there is no limit for total maps size stored in the server. If you do have sufficient space it should absorb the new map. There is some overhead for temporary operations, but having 400+ GB available points that the problem is not with the disk space.

I have a map1.tif with 99MB. I make copies map2.tif and map3.tif.

Map1.zip has 14MByte and uploads correctly.
If I add map2.tif to the Zip, the Zip has 28 MB and uploads correctly.
If I now add map3.tif, the Zip has 42MB and upload gives error.

Hence, it is not the tif, which akes the problem, but the size of the Zip file.

I delete the map3.tif from the Zip and add a smaller tif - the Zip has now 29,955KB and fails to upload.

Hence, the Zip file limit is between 28.325 and 29.955 KB - strange value.

An additional information: After the upload failed, the Zip file is still blocked by the SS, I cannot rename it or delete contents.

The exact value is 28.6MB as per Microsoft’s documentation:

And this default restricting value may and should be changed if you are working with larger files.

Thanks. This sound very helpful but I don’t understand why my IIS does not behave that way. I configured it manually in the web.config of the SurveySolutions web site, I then see it in IIS Manager in the RequestFilteringSettings / Edit Feature Settings panel. And I configured all of it also for the Web Server, so it should even be the default for all my web sites on that server. And I restared the Web site, the IIS and even the server.

Well, either this setting is override in some other config with a higher precedence, or there might be some other intermediate which imposes its own limit. Without fully knowing your infrastructure, configuration settings and versions of all the software involved it’s a wild guess. For example, a WAF may introduce its own restriction on the size of the queries, see for example the Azure WAF reference here:

Because the other installations of Survey Solutions don’t experience this limitation, it is unlikely to stem from our code. Instead, seek for something like this.