Local Server Deployment - GoogleMaps, ReferenceError: google is not defined

Hello, I have deployed a local SurveySolutions server and so far so good. However, I am not able to get the Maps feature setup. In the tutorial (https://support.mysurvey.solutions/headquarters/config/standalone-installation/), it is written that in the file appsettings.production.ini the snippet:

[GoogleMap]
ApiKey=%your api key%

should be added. I have added this snippet and created a Google API (https://developers.google.com/maps/documentation/javascript/get-api-key; restricted allowing only these 3 APIs: Maps JavaScript API, Places API, Geocoding API) the SurveySolutions server still gives me an ReferenceError: google is not defined error. Does anyone know how to solve this one? I have added the key as following (please note that this is NOT the real API key, but just an example)

[GoogleMap]
ApiKey=123459250349850938ß3409alkjsdlkajd

Thank you for any pointers on how to get this working!

Can you restart the server in IIS and try again, please?

I have already done this multiple times. Thanks for any other pointers

In order to be sure that application is restarted with new settings please execute command with administrator privileges: iisreset.
Another thing you can check using chrome browser navigate to map report page, hit f12 to open dev chrome dev tools and refresh page. Find request to public API and check if your key from settings is written there:

Also goole api key can be assigned to be used only by certain public DNS names. Does it match with your installation?

Thank you Andrii, if I check with Chrome Developer Tools, I do get the following feedback (I have just blacked the Website URL and parts of the API key):

The API key fits - so it is the same as I have created in Google:

It doesn’t seem that response comes from google. Notice x-Powered-By value. Have you changed only api key? Such error might be if you misconfigured ApiBaseUrl or BaseUrl in [GoogleMap] section.

I am having the same problem as Sandra. Andrew, can you supply an example of how the [GoogleMap] section should be configured?

That is ok, I figured out what you were saying, I included these lines in the [GoogleMap] section:

ApiBaseUrl=https://maps.google.com
BaseUrl=https://google.com

Google maps works ok now. Thanks!

1 Like

Many thanks - after adding

ApiBaseUrl=https://maps.google.com
BaseUrl=https://google.com

to the appsettings.production file GoogleMaps is working now! :partying_face:

1 Like

The same solution is still not working to my side, may you check my appsettings.production, if properly configured please?

You don’t need [GoogleMapSettings] section. Keep only [GoogleMap]. Please check support article regarding google maps setup