Interviewer not connecting via HTTPS on local server installation

Hi,
we are experimenting problem connecting interviewer app via HTTPS. Our local installation is on Windows Server 2016. We use a self-signed certificate, locally installed on Android tablets.
We can connect without problem by browser in HTTP and HTTPS.
Interviewer application only work via HTTP.

We have already tried this solution: https://support.mysurvey.solutions/faq/local-installation-interviwer-app-cannot-connect-to-the-server-over-https/

IIS shows correctly http/1.1 instead http/2 protocol, but nothing changed, interviewer app cannot connect. We have rebooted server and android tablet without success.

Could an installation on 2012 server could work? The institution in witch we are implementing the survey prefer to work with last version operating system.

We have already send a mail at with attached logs (IIS and interviewer) support@mysurvey.solutions.

Our pilot start next week, and we would avoid to expose the site on HTTP cleartext protocol.

Thank you for supporting.

Regards

Just for add more information. I’ve just tested a Windows 2012 R2 installation and get the same error.

The survey solution version that we are using is 19.10. I’ve see that a new version is available (19.10.1) and will try to test it as soon as possible.

To be more detailed, this is the command that i used to generate certificate in powershell:

New-SelfSignedCertificate –DnsName %SITENAME% -TextExtension @(“2.5.29.19 ={critical} {text}ca=true”) -CertStoreLocation “cert:\LocalMachine\My”

The CA=true parameter is needed to correct importing in android devices under User/Trusted Credential. Android chrome browser show the survey site trusted after certificate manual import.

I’ve tried also a wildcard certificate and using a bigger key lenght 4096 without success.

Do you know if there is a particular limitaiton about using self-signed certificated, or a particular procedure/parameters to generate it? For the pilot survey we have not the possibility to get a public certificate, but we want to avoid to expose survey without encryption.

Thank you for the support