Installation problems: Survey Solutions already installed

So we have Postgres 10 installed on our server, but when we try to install SS on Windows Server 2016 we get an error that it is already installed. Nothing appears in add/remove for SS.

The following errors appear in the log file.
[0744:0784][2021-05-04T22:17:17]i301: Applying execute package: IIS_Manage, action: Install, path:
C:\ProgramData\Package Cache\774F340B85465B4B476ABC35B50F8FDCC975C541\prepare.iis.bat, arguments:
‘“C:\ProgramData\Package Cache\774F340B85465B4B476ABC35B50F8FDCC975C541\prepare.iis.bat”’
[2A50:2A54][2021-05-04T22:17:24]i319: Applied execute package: IIS_Manage, result: 0x0, restart: None
[0744:0784][2021-05-04T22:17:24]i301: Applying execute package: dotnet_hosting_5.0.2_win.exe, action: Install, path:
C:\ProgramData\Package Cache\45F08415DC91EF20080DE770193218FECD5BC27A\dotnet-hosting-5.0.2-win.exe,

arguments: '“C:\ProgramData\Package Cache\45F08415DC91EF20080DE770193218FECD5BC27A\dotnet-hosting-
5.0.2-win.exe” /install /quiet /norestart /log

“C:\Users\xx\AppData\Local\Temp\SurveySolutions_20210504221708_001_dotnet_hosting_5.0.2_win.exe.log” -
burn.filehandle.self=1292’
[0744:0784][2021-05-04T22:17:25]e000: Error 0x80070666: Process returned error: 0x666
[0744:0784][2021-05-04T22:17:25]e000: Error 0x80070666: Failed to execute EXE package.
[2A50:2A54][2021-05-04T22:17:25]e000: Error 0x80070666: Failed to configure per-machine EXE package.
[2A50:2A54][2021-05-04T22:17:25]i319: Applied execute package: dotnet_hosting_5.0.2_win.exe, result: 0x80070666,
restart: None
[2A50:2A54][2021-05-04T22:17:25]e000: Error 0x80070666: Failed to execute EXE package.
[0744:0784][2021-05-04T22:17:25]i351: Removing cached package: dotnet_hosting_5.0.2_win.exe, from path:
C:\ProgramData\Package Cache\45F08415DC91EF20080DE770193218FECD5BC27A\

Can you please help with what else we can try?

Guessing here, but according to this, such an error may be caused by a conflict between two versions of the Microsoft Visual C++ redistributables. (2015 vs 2017).

Could you please check what is installed and remove the 2017, if possible, then install Survey Solutions, then reinstall the uninstalled redistributable.

Thank you very much sergiy