Export service not running

Survey Solutions user Danie de Klerk has sent us the following question:

The export service on one of my production server have stopped running.When I do a health check I get this error:

   System.Net.Http.HttpRequestException: An error occurred while sending the request. --->
   System.Net.WebException: Unable to connect to the remote server ---> 
   System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:5000

The message further contained recommendation to install an update from the Microsoft’s site. The installation of this update didn’t change the situation.

Danie has figured out the solution to this problem and has written the steps in the message below.

Hi Sergiy
I tried a few things that did not work. then Zurab advised me to reinstall on my base installation(I have a few headquarters on the same virtual server. but I always keep my 9700 port as the base installation with no questionnaires or data. I use this installation to create the other instances 9701, 9702 etc).
When I ran the installation(same version that I had 19.12) it asked me to repair or uninstall and I chose to repair(with all other instances stopped to avoid conflicts). I started the base instance and could see that the export function was working. I then started the other instances one by one testing the exports of each instance before starting the next one. It worked an the export service is restored. Thank you and the team for your help and assistance.