Error when downloading maps

Hi, I am trying to download tpk maps to tablets but I keep getting the error:

“Synchronization was interrupted, please try again
Unexpected exception”

When I check the device logs, the following error line is present for each time I attempt to download the maps:

21:43:48[MapSyncProvider][Error][Synchronization. Unexpected exception]System.UnauthorizedAccessException: Access to the path '/storage/emulated/0/TheWorldBank/Shared/MapCache/' is denied. ---> System.IO.IOException: Permission denied

Which seems to indicate that there’s a permission issue when trying to create the map directory. However, the Interviewer app has storage permission allowed and I’ve tried this on three tablets with the same result. All of the tablets are new and set up for this purpose.

The tablets I’m using are three Samsung Galaxy Tab A (8.0", 2019) tablets running Android 10. I’m deploying from a local server

Hello Dtrotman,

What is the version of the Interviewer App?

  1. check (with a file browsing application) if the folder actually exists.
  2. if it does exist, try to rename it to anything else and retry the Interviewer maps synchronization.
  3. If it doesn’t exist, try to create it manually with the name indicated in the error message and see if there is any other explanatory message. If no error message, then retry again.

The interviewer app version is 20.09.
/storage/emulated/0/TheWorldBank doesn’t exist. I created the folders as shown in the error without any issue. When I tried to synchronize the maps again I got the same error.

  • If the tablet contains any unsynchronized data, send it to your server.
  • Uninstall the Interviewer App.
  • Create an account at the public demo server or request a PDS.
  • Install the most recent version of the Interviewer App from that server.
  • Retry with that version.

If the problem does not reoccur, update your server and Interviewer installations on all tablets.

Hi Sergiy,

I followed your troubleshooting steps and found that it works without errors on the demo server. I updated my server and android app to 21.01.3 and it works there as well.

Thanks for the help.

Great!
Thank you for confirming!