Error trying to access demo server using python api

I get an error when I try to access the demo server using R and python api. To add on that am unable also to connect tablet with the PDS. Any leads?

ssaw.exceptions.GraphQLError: Your account is in the workspace disabled by the system administrator, and as a result you can't use the functionality of this site

The error message specifically mentioned the reason why the access is not allowed.
Please use a user having access to the current active workspace.
You are trying to reach out disabled workspace.

For the second part there is no details and it’s hard to tell. Please elaborate.

Even after creating ApiUser and granted access to all the available workspaces I still get an error. I keyed in the same exact passwords that I had assigned to the ApiUser and still get:
ssaw.exceptions.UnauthorizedError: Either username or password were not provided or wrong

Interestingly, even after explicitly specifying the workspace, the access is not granted

I finally got a workaround it! Thank you!!!

So what was the workaround?
This would be useful for other users that may encounter a similar situation.

I had very small typo in the credentials

Ok, thank you for explaining.

  1. Finding a “workaround” means that there is a problem with our system, and you found a way to achieve the desired result, within the limitations, but perhaps with a not-straightforward approach, having extra steps, etc.
  2. In this case there is no problem with our system, but there was an error with your script using it. Writing “I finally got a workaround it!” confuses more, as it implies the problem exists, when it is not.
  3. It is important WHERE you had a typo in the credentials. You’ve cited a particular error message from ssaw:

Your account is in the workspace disabled by the system administrator, and as a result you can’t use the functionality of this site

Where did you have a typo?

  • In the address of the site?
  • user name?
  • password?
  • workspace?

I find it unlikely that you had a random typo and ended up in a disabled workspace rather than enabled one.

It was the password that I had missed.