Error on the Interviewer App


Hello everyone

Im trying to link the interviewer App with the Survey Solution hosted on premise but i can’t succeed due to error in the picture.

  1. Can the same tablet connect to a PDS or the demo server? (make sure the App version is the same)
  • If yes, then the problem is likely with the server setup, rather than with the tablet.
  • If not, then the problem is likely with the tablet. Correspondingly, take a different tablet that can connect to the demo server and try to connect to own server.
  1. Try the WiFi instead of 4G and see if it makes any difference.

Thanks Sergiy

The tablet is working with the PDS/ Demo Server. Is able to login. And I tried the 4G/WiFi with on premise Server still I can’t succeed to login I get the same error. The App and the Server are on ver. 20.12

According to the tablet working with the PDS simply means there is nothing wrong with the table. But what could be wrong on the Server side. Please assist.

Try to login to the server from the tablet while being connected to the same local network (without internet). If you are not controlling the server, please, contact the server admin to gain this direct access.

  • If can connect, then the problem is with the connectivity/firewalls etc. => contact the network admin
  • If still can’t connect, then the problem is with the server machine itself => then perhaps, reinstall Survey Solutions following the recommended installation instructions

Good day Sergiy.

Find attached picture. It worked with internal same local network. Thanks

But we want to use it outside on the internet. Please advice on the connectivity/ Firewall issues.

This is good news. So, both the server and the mobile components of Survey Solutions work fine, but there is something in your network that prevents them from talking to each other.

As I wrote earlier, if this is the case you need to contact the network administrator in your organization to either report the problem and let them deal with it, or obtain a full list of tools and technologies that are utilized in that network that can potentially intervene, obtain the rules and configuration for each of them, etc, etc. This is specific to your organization, so forum members can only come up with guesses.

My personal guess is that it is not a firewall, which in case of simple denial of access would result in “Synchronization was interrupted, please try again. No connection to the Survey Solutions Supervisor. Please make sure that the website is available.” or similar message. Instead, I believe it is some other security mechanism, that tries to paint a human-friendly message, which would be appropriate for a human user, but since it is received by the program, it is not understood, which in turn results in the “UNEXPECTED ERROR” seen on your screenshot.

.
Good day Sergiy

Find attachment. This is the Error from the Squid that the interviewer App is getting and unable to interpret. That why I’m getting “UNEXPECTED ERROR” on the App. Should this mean that our administrator need to do changes on the Squid or What. Please advice.

Well, here is the culprit.

Now is the time to contact that person whose email is in the message and explain that this tool is causing you problems. If the tool in principle is configurable to permit such things, perhaps you can convince them to do an exception. If not, or if their rules do not allow it, consider hosting elsewhere.

But more importantly, your current screenshot shows that you attempt to setup a server on HTTP rather than HTTPS. Survey Solutions will work either way, but this setup will not be secure and should not be used for any sensitive data handling (see installation instructions).

Since this Squid tool doesn’t seem to be compatible with HTTPS (according to Wikipedia), this may be not a suitable placement of the server.

Contact the StatsSA to check if they can set up this server for you using their facilities.

Good day Sergiy

I need some additional information. I experienced that login through the web browser using internet is not an issue I can even do the questionnaire while online. So in point form I need this information: what protocol and ports does the web uses and what does the App uses. Secondly can your development team do changes on the App so that it matches what the web browser uses in terms of protocol, port and network Traffic?

Survey Solutions will use the protocol and port that you specify.

You specified protocol HTTP (evidenced from your screenshot) and didn’t specify the port, meaning the default port for that protocol will be used. Googling for the obvious we confirm that it is


The server is responding on that port:

Thanks Sergiy

We managed to move the Survey Solution App to Azure. And now it is working both on the mobile phones and on the browsers.

Thank you for confirming that switching from ‘on premise’ to Azure infrastructure has helped to resolve this issue. Still it is not clear what was causing it, but the change has demonstrated that it was something attributable to the internals of your network configuration.

Wishing you a successful survey!