Error occured when installing survey solutions app multiple times on same server

Currently I am running survey solutions on my local server (1.2.3.4:80). But for another project I cant use the same installed survey solutions app(Because I have to share login details). I followed the details from this thread Different modes of deployment for multiple surveys . so here’s what I tried to have multiple survey solutions app on same server:

1- Copied Installed “Survey Solutions” folder from C: and pasted on C: and renamed as “Survey Solutions 2”.
2- Created a new DB on postgresQL for new Survey Solutions app.
3- Edited “appsettings.production.ini” file and updated the name of DB created in step 2.
4- Added new website on IIS and changed the listening port to 81 so that I can access it by 1.2.3.4:81 and also added physical path to “C:\Survey Solutions 2\Site” from step 1.

after doing all of the above and trying to access the app by typing 1.2.3.4:81 I get the following error:

HTTP Error 502.5 - ANCM Out-Of-Process Startup Failure

Common solutions to this issue:

  • The application process failed to start
  • The application process started but then stopped
  • The application process started but failed to listen on the configured port

Troubleshooting steps:

  • Check the system event log for error messages
  • Enable logging the application process’ stdout messages
  • Attach a debugger to the application process and inspect

For more information visit: https://go.microsoft.com/fwlink/?LinkID=808681

Is there anything that I missed while adding a new app?

Hello Yubraj,

as Zurab has written in his advice, this is rather advanced, meaning it is difficult to set up, and even more difficult to diagnose what might be wrong when it is not working smoothly. So try to install different Survey Solutions instances onto different servers where they will be isolated from each other.

The message that you quoted contains possible reasons, explaining the nature of the problem. For example, take “The application process started but failed to listen on the configured port” and investigate. It could be the port is already used for other purposes, for example, this source


mentions that it may be used by McAfee Framework Service

Zurab’s advice should work provided that you start by taking a blank HDD, install a Windows Server with default settings, and install Survey Solutions using the indicated sequence after that. As long as there is any other step or change involved before (or in between) this may no longer be valid.

As advised in the message, the logs may be helpful in trying to determine the reason (and it may or may not be related to Survey Solutions at all).

​Since you are writing that the first instance of the application is working, this rules out the “failed to start” reasons due to missing dependencies (such as .Net core), which may also provoke this error.

Best, Sergiy

Hi Yubraj,

It’s a known .NET Core issue.
You may use this workaround:

In the web.config file of copied site change this line

<aspNetCore processPath=".\WB.UI.Headquarters.exe" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" arguments="" hostingModel="OutOfProcess" />

with a section:

<aspNetCore processPath=".\WB.UI.Headquarters.exe" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" arguments="" hostingModel="OutOfProcess" >
<environmentVariables>
<environmentVariable name="DOTNET_BUNDLE_EXTRACT_BASE_DIR" value=".\hq"/>
</environmentVariables>
</aspNetCore>

Please be careful with connection string parameter in your copied instance.
Do not forger to change Database name and keep it correct if you update second instance in future.

Thank you so much. . this worked for me