Error deploying Designer in docker container

We are trying to deploy SuSo Designer in a docker container. We are running the deployment procedure published in SuSo Github:

docker pull Package surveysolutions/designer · GitHub

We tried in two different docker containers (based on Mac and Linux) and in both, we are getting the same error (apparently the postgresql database inside the container is not listening in 5432 port)

At this point Designer is not intended to be used on premises.
We would also discourage you to move in this direction.
We do not provide any support for Designer infrastructure and following updated of Designer code could be not directly applicable to the previous versions.

Thanks @vitalii for your response.

The plans for deploying Designer on-premise were raised after the digital certificate expiration event that happened on July 13 . NSO team was working on a questionnaire and their work was interrupted for some hours. At this point, NSO managers expressed their intention for deploying Designer in their own infrastructure and asked me for help to perform this task. But now I understand the restrictions you mention. Thanks

Sorry for inconvenience - we made some infrastructure upgrades that caused some short service interruption.