🔥 Designer subsystem failure to compile questionnaire on HQ request

As can be seen from the following traffic the Designer subsystem is currently experiencing problems issuing compiled questionnaires on demand to the HQs import requests.

This is despite the questionnaire editing functions provided by the Designer are working normally.

https://forum.mysurvey.solutions/t/fail-to-import-questionnaire-to-headquarters-please-contact-support-to-resolve-this-problem/4410/2

https://forum.mysurvey.solutions/t/problem-importing-questionnaire/4408/2

https://forum.mysurvey.solutions/t/failure-to-import-questionnaires-from-the-designer/4407/2

https://forum.mysurvey.solutions/t/problem-uploading-questionnaire/4401/2

https://forum.mysurvey.solutions/t/questionnaire-import-not-working/4400/2

https://forum.mysurvey.solutions/t/fail-to-import-questionnaire-to-headquarters/4396/2

https://forum.mysurvey.solutions/t/fail-to-import-questionnaire-to-headquarters/4394/2

https://forum.mysurvey.solutions/t/error-importing-questionnaire/4392/3

Please do update this thread with any information about:

  • Workarounds. (Not sure there are any)
  • Timeline for a hotfix

I am not aware of any workaround for this issue

The issue seems to be reproducible with any questionnaire and results in the same message.

Sometimes it gets stuck on 68% indefinitely, and sometimes it displays the aforementioned error message. Before I saw this thread, I tried importing on different servers and with different questionnaire sizes and none imported successfully.

Hello everyone,
Same observation for me, a lock at 68%, then the “Fail to import…” error message on retry.
The latter is explained by the locks that do not disarm under postgresql. I have to restart IIS or postgresql to release the locks, but the 68% blocking remains… Good Luck

Hello Sergiy,

Thanks for getting back.

We deployed staff into the field on 20th and waiting day 2 today. Would you advise we continue waiting (if there’s hope of resolving this) or perhaps we make plans to go the paper?

Hello @ISEE, could you please elaborate on Postgresql locks in relationship to the above problem?

Hi,

Personally, changed the locks from standard 64 to 1024 yesterday, cause of failing Exports, and was solved after that. Not sure if it is related with today’s error of Importing questionnaires.

I am having the exact same issue as well. Your help or guidance on this matter would be really appreciated.

Many thanks and best regards,
Evgenyi

1 Like

The issue seems resolved on our end. Thanks, Team!

Bonjour l’équipe,

je voudrai importer un questionnaire, et je reçois le message suivant:“Fail to import questionnaire to Headquarters. Please contact support to resolve this problem.”

ci-joint la capture d’écran

1 Like

A few minutes ago, I checked and was successfully able to import a questionnaire from Designer to HQ. Has the problem been resolved?

I can see three questionnaires imported to the Demo server today


and received several notifications where direct mail that the import has eventually succeeded.

Before concluding that the issue has been resolved, can we have a count of hands of those who are still experiencing problems? (if anyone).

If the import of the questionnaire doesn’t succeed immediately, please wait for 10 minutes and retry before reporting as not working. Please indicate the time of 1st and 2nd attempts in your report and any other details that you can provide.

Best, Sergiy

1 Like

All working well for me. Thanks for your efforts!

Best,
Borja

Hi,
I confirm that the import is working again.
Thanks to you for your reactivity.
@sergiy Indeed, I assumed the fact that the import process does not reach its end should leave active locks on the database. Locks that seem to be activated at the start of the import process. Hence a first message blocking at 68%, then the error message when trying again. To remedy this, perhaps we should integrate a timeout on the import process ?

Hi,
It’s not working anymore. The same problem.
“Fail to import questionnaire to Headquarters. Please contact support to resolve this problem.”
Please help @sergiy !

Hi everyone,
Thanks for your efforts about this, but the exact same problem here too. The first attempt ended up getting stuck at 68%. The second attempt cannot proceed at “Receiving questionnaire data”. I also could not publish/download the questionnaire as a PDF on the questionnaire designer site. Thank you.

1 Like

Hi everyone,

Thank you for you efforts but the problem remains.

  • First attempt in one sever (https://selever-surveysolutions.ifpri.org) at 9:12am GMT : stuck at 68%. I tried in a second server (https://iram-surveysolutions.ifpri.org/mali) at 9:14 am : also stuck at 68%.

  • Second attempts at 9:48 and 9:50 am GMT had the message :
    “Fail to import questionnaire to Headquarters. Please contact support to resolve this problem.” for one server and importing stuck at 68% for the other.

Many thanks and best regards

Hello

I have had the following problem when exporting to my test server and my work server, the error has been persistent for 3 hours and I have not been able to solve it, the form does not contain error compiles fine in the designer, on Friday it was working fine.

“Fail to import questionnaire to Headquarters. Please contact support to resolve this problem.”

What can I do in this case? Please help

I Am having similar problems importing questionnaires,
Am running survey solutions 21.09.9 (build 32035)
on a self hosted server. Previously I have been able to import questionnaires on the same server.

Below is the error it is giving when I try to import;

"Fail to import questionnaire to Headquarters. Please contact support to resolve this problem. "

Please assist