CAWI survey links request a certificate to authenticate on some Windows machines

Dear Survey Solutions Team:

I am testing a questionnaire in CAWI mode, so I sent links to a few colleagues, but turns out two of them (so far) who are running Windows OS get asked “Select a certificate to authenticate yourself to jifsurveysolutions.umd.edu: 443”. The options are “OK” and “Cancel”. Selecting OK led to a “403 - Forbidden: Access is denied”. Selecting cancel activated the link fine. The link also opens fine in MacOS without any problems. We are using Survey Solutions installed on a AWS VPC provided to us by the University of Maryland (UMD) DIT. We thought the issue might have something to do with UMD’s network, but we had someone outside UMD’s network open the new link on a Win OS, but faced the same problem. The SSL certificate was just installed and is valid till next year. My IT guy suspects a Survey Solutions software issue related to Windows machines, and I thought I should check in if someone else has that issue and suggestions for a workaround. A simple way might be to cancel the request but that does not engender confidence in the survey platform for project management, especially with high alertness for data security. I will be grateful for any help on this. Screenshots are attached.



Thanks.

The truth is probably somewhere in the middle/none of the above, see: Prevent browser from prompting for client certificate for IIS app.

In short, your Survey Solutions is set up behind IIS and the requirement for the authentication is coming from IIS itself. Hence must be configured/re-configured there. This also explains why the person accessing from an outside network was requested to authenticate with a certificate.

Please let know if this solves it by marking the solution.

Sergiy, It WORKED! Now they can all open without problems.Thanks a lot!

I run ‘inetmgr’ on the server, selected SSL Settings under Survey Solutions, and selected ‘Ignore’ for Require SSL. Then I rebooted my instance! That’s it!