CAWI: cannot retrieve the link for web mode self-completion

I would like to ask about CAWI, after reviewing all the instructions on the website, I’m still unable to get the link for web mode or distribute the survey.

  1. Firstly, I already enabled the web mode, so it shows as “Yes” and click start web mode on the green button

  2. I choose the command to not specify the email and password (not plan to use bulk email service), I just need the link to distribute to the respondents. Also tried to specify email, it did not come through

  3. When I click “download web link”, I tried to copy the link and paste it into my browser but it did not work. For example, http://localhost:9700/WebInterview/L6FDWLHH/Start, but it still did not work

  4. On the other hand, when I click “send invitations”, it shows as below. I set it up as “None” for bulk email service but it also did not work.

  • Invitations can’t be sent.
  • SI001: Email provider is not set up. You can change these settings at the ‘Email Providers’ page.

Your help would be much appreciated. Thank you for your support in advance.

What does localhost mean?

I’m also not sure, the link was generated like this. But I wonder if it is our cloud server?

What is the URL of your cloud server?

Our URL is: http://43.229.78.151/

I’ve found it. See below Victoria explains what localhost is:

Thank you Sergiy. I’ve watched the video but still don’t understand how the link for the survey was generated and how we can distribute it. For example, like Google survey, respondents will only need a link to complete the survey.