Can't connect to the server


We have just set up a new standalone server (with SSL enabled) for a new survey.
Everything has been set up, but we can’t connect using the Interview app using tablets.

Basically, every time we try to login (or run a connection test from diagnostics section) the app crashed right away.

Tried on 2 different devices, using both wifi and 4G. Same issue.

Survey Solutions 20.07.3 (build 28992).
Mobile app version 20.07.3 (build 27765).
Android 8.0.0

Note that only ports 80 and 443 are opened for incoming connections to the server.
May this be an issue…?


1 Like

I have edited the forum post of this user from the original “Android App keeps crashing” to “Can’t connect to the server”, which I think better reflects the situation. Kindly avoid overstating or misrepresenting the problem in an attempt to draw more attention or significance to it.

Now, in your post I see a screenshot, which shows a properly formatted error message indicating that the tablet can’t reach the server. Is that what you have meant by ‘crashing’???

Apparently not everything. But it is not possible to comment, because you don’t provide any details.

Perhaps, the first thing you can do is to try to connect one or both of these devices to the demo server (which is running the same version now as your server), by creating an Interviewer account there.

  • If they connect and talk, then it is not a tablet, but a server issue, and you will need to explain more.
  • If the issue is reproducible with a demo server, then we can at least look at the backstage for diagnostics.
1 Like

Hello Sergiy,

Well it has been really difficult to take that screenshot, because the error message appears in a flash right before the app is closing (which seems like crashing because it happens so fast).

Anyway, I get your point, this is not the issue here.

We have tested it with the demo server and it works fine. We just sent the tablet information to HQ via the diagnostics tools.

This is what I see in headquarters.log when trying to access our server from the tablet:

2020-08-05 07:46:01.721 +11:00 [INF] HTTP GET /Interviewer/Profile/fff1d944-a2ae-4546-9c9e-3de9f6177e36 responded 200 in 97.7322 ms
2020-08-05 07:46:02.941 +11:00 [INF] HTTP GET /Interviewer/TrafficUsage/fff1d944-a2ae-4546-9c9e-3de9f6177e36 responded 200 in 6.3794 ms
2020-08-05 07:46:34.485 +11:00 [INF] HTTP GET / responded 302 in 0.2485 ms
2020-08-05 07:46:34.531 +11:00 [INF] HTTP GET /Account/LogOn?ReturnUrl=%2F responded 200 in 4.8314 ms

So I guess you need more explanations… What information can I provide to help?

1 Like

This looks like these queries are not from the tablet, but from the interactive work with a browser (but the screenshot in #1 is from a tablet). Anyone accessing e.g. the root of the demo server will get a similar 302-redirect to the logon page.

I don’t see anything so far to suspect a ‘ports issue’ (as in #1).

Has this ever worked? With any tablet? If yes, what were you doing when it stopped working?
Was this updated from an earlier installation? Or is it a completely blank setup?
Is the HQ-site accessible from a browser on a tablet? If not, what does it say?
Does the server respond to https only? or http as well? Anything else running on the server?
Can you try without a certificate and see whether it makes a difference?
Can you place the server in a different network and see whether it makes a difference?
Can the tablet connect via a server’s local network?
Was the tablet App installed from the same site?
Does it ‘crash’ if you check for updates from the App Diagnostics?
Does it ‘crash’ when you try to send tablet information to the local site?

No idea at this time. But if even the diagnostics screen doesn’t work, then I can only imagine some low-level networking or a certificate issue.


Thanks for your reply.

We access server’s SSL port through Cloudflare to manage security, including the SSL certificate.

Is there any known issue with Cloudflare?

Looks to me like this is probably where this issue comes from.

This is a new setup, on a brand new server.
Nothing else is running on the server.

Connecting using a browser works fine, but can’t connect using the Interviewer app.

Yes, works fine.

IIS listens to 80 and 443, for the one and only site defined (Survey Solutions).

Using port 80 and server’s IP address directly seems to work!
(which seems to confirm this could definitely be an issue with Cloudflare)

Not at this point.






Dear Stan,

thank you very much for providing this additional information. Please update to version 20.08 released earlier today. It should address the reported incompatibility. If the problem persists after the update, please contact support email.

Best, Sergiy Radyakin

All right, great!
Will try that right away.

But actually… How do we properly update Survey Solutions?

Ok so since the survey hasn’t started yet I just uninstalled 20.07 and installed 20.08.
And great news, it now works!
We’re still testing but it looks good.
Thanks a lot Sergiy.

1 Like

Glad it worked.
Thank you for confirming!