Bugs / change password / QR code

Hi.

When i login as supervisor and i want to chage password i get error
“Not found”
there is missing workspace in link https://server/Primary/Users/ChangePassword

When i login as interviewer i there is missing option to change password.

And one more thing, when I (supervisor) want to set tablet by QR code I have to delete workspace manualy at the end of string to connect to server.
Also i have to change http to https but this is not a bug maybe.

Thanks
MB

The issue with the “Not found” is not reproducible. Please provide more details.

Check the BaseURL setting for your server.

And there never was a possibility for an interviewer to change own password.

I`m logged in as supervisor and i want to change self password. (Change password for interviewer is working good.)
When i click on change password.

I got this.

I have to manualy add workspace to http adress to get to page for change password.

Not reproducible following the steps provided.

VIDEO

Okay, it`s weird, but it looks like problem is only on our server.
Do you have any idea what could be a problem?
Is it possible to something kept in system from old version 20.12 after we update to 21.01?

@martinb , unlikely.

But you can check against it by creating a new supervisor account already in v21.01, then repeating your actions.

You could also try to change the password of this supervisor as an admin and see what happens (should be always possible of course), then retry if it succeeds from under the supervisor account.

There were 8 releases within the v21.01 generation, and each patched one or more different problems. I assume that you are using the same contemporary v21.01.8 as on the demo server at this moment. If not, it is a good idea to look at the bottom of the screen now (can’t be seen on your video or inferred from anything else) and update.

See what else is not working or behaves strangely. That could hint more directly at the nature of the problem.

I can’t immediately see how that could manifest itself in such a weird way, but your security software could do more than you’ve bargained for, if it is doing some sort of smart address manipulation, rewriting the URLs or doing some other magic. Clearly only you would know.

Note that Survey Solutions will try to redirect the query from without workspace to with workspace:


We have installed probably first version 21.01 (build 30288).
Thats probably biggiest problem. I didn`t noticed small updates because I was checking only release notes.
Can I see a changelog for this small updates somewhere on your page or forum maybe?

Thank you.

Unfortunately, the release notes cover only the addition of features, which happen in X.Y releases and never in X.Y.Z hotfixes, which fix the already announced functionality.

I do not recognize the issue that you are describing as a known issue, so I don’t expect that this would be working out of the box after the update, but that would narrow down the differences with the version I was experimenting with.

If anyone else experiences the same, please do let us know any additional insights from your angle.

@martinb , do you have any new info on this issue?

You could also try to change the password of this supervisor as an admin and see what happens (should be always possible of course), then retry if it succeeds from under the supervisor account.

I tried change password as admin for Supervisor. It works okay.
I tried change password as admin for self (Admin). Not working - same error “Not found”. (missing workspace)
I created new user Supervisor, change password for self - Not working - same error “Not found”.(missing workspace)

I found one more thing. Problem isnt only to change password for self.
I Cant open profile and two factor authentication also. There is same problem - missing workspace.

But when i click on user name and “Manage account” user profile load correctly. (link is woth workspace)
When i clict on tabpage ( Profile, Change password, Two factor authentication) I got error not found.

image

This is all I found, hope it helps little bit. I understand how hard is to fix it when its not reproducible.
I let you know if i found something more, or after update if will something change or not.

We already started first testing of Survey Solutions for Interviewers.
We can`t update Server to 21.01.8 right now because we already sended preinstalled tablets to interviewers and it could be difficult for them to update aplication Interviewer in their first touch.
We will update server to newer verion in June.

Thanks
MB

@martinb , updates of the server do not always result in updates of the tablet app. In case of the 21.01 version the last 4 patches 5,6,7,8 were not affecting the Interviewer App. So whether the server is 21.01.5 or 21.01.8 the newest Interviewer App that it offers is still only 21.01.4 and should continue working seamlessly with the tablets that you’ve setup without demanding the updates to the client app.

Best, Sergiy Radyakin

We installed apps from our server witch is version 21.01 so we installed to tablets verion 21.01.01
image

Now i understand how you change versions more clearly.
Thanks for info.
MB

New version fixed all problems. (21.5.3)
Thanks
MB

Thank you for the confirmation @martinb