Base map not displayed

Hi,

We are running a survey that asks participants to identify their fields. The plan is for participants to identify their field based on a vector layer of field boundaries overlaid on a satellite base map. We have successfully created a .tpk of field boundaries, which displays correctly on the tablet. The .tpk is in WGS84 (ESPG code 4326). However, no base map is displayed. Does anyone know how to display a satellite base map (Ideally ESRI imagery)?

We are using version 19.06 and unchecked the exclude ESRI Map Support box on installation.

Thanks in advance

LH

This seems to be a contradiction. Is it displayed correctly or not?

Hi Sergiy,

Apologies for the confusion. I have attached a screenshot of our map. The orange lines are the field boundaries but as you can see there is no base map.

Regards,

Laurence

Laurence,
try the following:

  1. prepare the TPK file with just the baseline map.
  2. load onto the tablet and make sure the baseline map (satellite imagery) is visible.
  3. prepare the boundaries as a shapefile
  4. upload the shapefile to the tablet
  5. see if the shapefile is properly overlayed

Do this first on a small area to exclude any sort of complications due to size/dimensions of the map data.

Best, Sergiy

Apologies for the slow reply. I’ve been trying to resolve my issue but have had no luck.

Unfortunately I have been having some trouble in preparing the tpk files with just the basemap, even for a small area. Ideally I would like to use World Imagery satellite data at Level 19 (so can see building level detail). I have tried creating a tpk from World Imagery for Export in ArcMap 10.6 but this fails. I have tried this workaround using Arc REST API, but have only succeeded in downloading imagery at level 14 even for a small area of 500x500m. As my AOI is approximately 4x4km I would like to avoid downloading lots of small tiles.
Therefore, i was wondering if anyone knows of a good guide to create tpk with basemaps?

Secondly, I thought I would test viewing the satellite imagery basemap as Sergiy suggested. The interviewer app wants to update to version 19.07 (from 19.06) before syncing the maps. However, I am getting the error ‘Calling startActivity() from outside of an Activity context requires the FLAG_ACTIVITY_NEW_TASK flag. Is this really what you want?’ on the diagnostics screen. We are running Android 9.0.

Please take a look on tool provided by Esri:

For update on Android 9.0 could you please download the latest version of Interviewer Application from you server using browser on the tablet and install it manually upgrading the previous version?

See also here for updating problems:

I recommend the open-source alternative QGIS, where layers and basemaps can easily be exported to GeoTIFF rasters, for example as shown here: